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Visual Accessors - New Feature Spotlight

Visual Accessors - New Feature Spot-
light

The ability to use visual accessors has been added to the Mobile Test Designer.
Visual accessors allow Mobile Designer to incorporate images into your test
scripts. Smart Tags Workbench and Mobile Blueprint have been enhanced so
that images are defined as Smart Tags and can be added to a Mobile Blueprint.

This new functionality is available for both Android and iOS mobile devices.

Mobile Designer enables script recording and playback, a simpler approach to
mobile test design than traditional mobile scripting. Using visual accessors

allows Mobile Designer to incorporate screenshots into scripts.

This documentation details how the image matching algorithm works, recom-
mendations for getting the best results when using this feature, as well as

information about setting up and configuring this new functionality.

Visual accessors for mobile testing is new functionality that will
be introduced in AlQ 4.9. This feature and this documentation
are currently in Beta.
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Understanding the Image Matching
Algorithm

The following section details how the image-matching algorithm determines if
the target and source images are a match. There are also some recom-
mendations and considerations for getting the best results when using the

visual accessor functionality.

How the Algorithm Works

Naturally, different images will have different numbers of distinguishing fea-

tures. An example of this is shown below.

O O
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Desired Features Low Features

The images in the “Desired Features” set have a significant number of dis-

tinguishing features that set them apart from the other images in that set.

The images in the “Low Features” set have a smaller number of distinguishing

features that set them apart from other images in that set.

Matching Process

* The first thing the algorithm does is compute the distinguishing feature

points for each image (target and source).




Understanding the Image Matching Algorithm

* Next, the algorithm applies a matcher to find similar features in both
images. For the matcher, a possible set of different algorithms can be
applied. In this case, it is a matcher that rejects outlier points that are

chosen to reduce the probability of getting an incorrect match.
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* Using the set of matched points, the algorithm constructs a region with the

same dimensions as the target rectangle bounding.

* The similarity between the target and sub-region source is calculated with

several parameters to determine if both are similar. If they are found to be
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similar, then the bounding box is returned.
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Recommendations and Considerations

Here are some recommendations and considerations for getting the best results

when using the visual accessor functionality.

* Multiple reference images for the same target. Along with the original-
sized image, you should have several images from the same target with
different sizes than the original size. Reference images should also
include both images taken from the Mobile Designer IDE along with
screen captures. Having reference images from both capture sources is
recommended because some bit depth differences can affect results

when the target image has limited distinguishing features




Understanding the Image Matching Algorithm

* Use images with less compression and better quality. The preferred image
format is PNG, but formats such as JPG/JPEG will give good results. PNG
is preferred because there is less information loss due to compression.
Images with more detail will have a greater number of distinguishing fea-

tures.

* Test your targets and possible sources. Before creating a full test run, test
the set of targets and sources to validate if the correct targets are chosen.

You can write a script to perform that task.

* Add context to images to help differentiate them from other possible
matches. This can happen if the cropping area is too limited and the num-
ber of distinguishing features is limited.

For example, an image with the word “ear” could have multiple matches
depending on how the image is cropped. If the image is cropped exactly
covering the word, the algorithm will also add “bear”, “spear”, “tear”, “boar”
and more as matches. Even “ear” could have “oar” or “eor” as possible
matches. So, when possible include some additional context in your image

to help with exact matching.







Visual Accessors for Android

Visual Accessors for Android

The following sections contain information about setting up and configuring this

new functionality.
» "Setting up the Environment" on page 13
* "Appium Server Setup for Android" on page 14
* "Device Manager Setup" on page 15
* "Android Studio Setup" on page 16
* "Adding App to Emulator" on page 21
* "Required Fields" on page 22
* "Creating a Smart Tag File for Visual Accessors" on page 25
* "Generating Images for Smart Tags" on page 27
* "Creating a Mobile Blueprint using Visual Accessors" on page 29

The following sections contain an end-to-end example of using the visual

accessor functionality with an example mobile app.
¢ "Android Mobile App Example" on page 31

» "Selecting the Mobile Device and App in the Device Manager" on

page 32

* "Creating a Mobile Configuration File" on page 36

-11 -
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* "Getting Access to a Repository" on page 41
* "Taking Images as Possible Smart Tags" on page 43
* "Creating the Smart Tag File" on page 45

* "Mobile Blueprint using Visual Accessors" on page 51

This is the documentation for the visual accessors feature for
testing Android mobile applications. The documentation for
testing iOS mobile applications can be found on the Visual
Accessors for Mobile Testing page.

-12 -
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Setting up the Environment

Setting up the Environment

AlQ Mobile Designer requires an Appium server and a Device Manager to inter-
act with mobile apps. The Device Manager functions as an emulator or bridge

interface for a physical device connected to a computer.
* "Appium Server Setup for Android" on the next page

* "Device Manager Setup" on page 15

-13-
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Appium Server Setup for Android

Appium is an open source test automation framework for use with native,

hybrid, and mobile web apps.
It drives iOS, Android, and Windows apps using the WebDriver protocol.

1. Download Appium Server from https://github.com/appium/appium-

desktop/releases/tag/v1.22.3-4

2. Choose the appropriate installer for your environment.

3. Launch the installer.

@ Appium - o X
File View Help

@ appium

Host  00.0.0

Port 4723

Edit Configurations 3

4. Follow the installation steps and select the default settings.
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Device Manager Setup

Device Manager Setup

The Device Manager you use depends on your platform.

* Android applications can use Android Studio IDE. You can download it

from: https://developer.android.com/studio.

* |OS applications use Xcode IDE. You can download it from, the Mac App

Store or from https://apps.apple.com/us/app/xcode/id497799835?mt=12.

-15-
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Android Studio Setup

Installing Android Studio

1. Download the appropriate installer for your environment from

https://developer.android.com/studio.

2. Launch the installer.

Android Studio Setup = X

Welcome to Android Studio Setup

Setup will guide you through the installation of Android
Studio.

It is recommended that you dose all other applications
before starting Setup. This will make it possible to update
relevant system files without having to reboot your
computer,

Click Next to continue.

Android
Studio

< Back . Next > Cancel

3. Follow the installation steps and select the default settings.

Configuring Android Studio
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Android Studio Setup

Setting ANDROID_HOME

Once Android Studio IDE is installed, add Global Environment Variable
ANDROID_HOME:

1. For Windows:

a. Navigate to Environment Variables > Settings > System Variables >

New.

b. Add ANDROID HOME withvalueofC://Users/Your User-
/Appdata/Local/Android/ SDK

ﬂ The above value assumes you accepted the default
path during installation. If you specified a different
path, enter that path for the value of ANDROID
HOME.

2. For macOS:

a. Opena Terminal and type: echo export "ANDROID HOME-
E=/Users/yourName/Library/Android/sdk" >> ~/.bash

profile

b. Close Terminal and open a new one and type echo $ANDROID

HOME to verify that the value exists.

3. ForLinux:

a. Open aterminal in the same directory of installation and sudo nano

.bashrc

-17 -
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b. Them add to the file: export ANDROID HOME-
E=${HOME}/Android/Sdk export PATH-
H=${PATH} : ${ANDROID HOME}/platform-

tools:${ANDROID HOME}/tools

c. Close the terminal and type in a new one echo $ HOME
Setting Android Debug Bridge Location

Android Debug Bridge (adb) is a command-line tool that lets you communicate
with a device. The adb command facilitates a variety of device actions, such as

installing and debugging apps. adb provides access to a Unix shell that you can

use to run a variety of commands on a device.
1. Open Android Studio IDE.

2. Inthe Tools menu, select SDK Manager.

3. Copy the SDK Location. “path_copied*

-18 -
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4. Copy the SDK Location. “path_copied*®

a. For Windows:
i. Openacmd console
ii. Type:cd path copied/platform-tools
iii. Type:adb help
iv. Verify that it works.

b. For Mac:
i. Open terminal

ii. Navigate to the directory: ~/Library/Android-
/sdk/platform-tools/

-19-
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iii. Type:adb help

iv. Verify that it works.

c. ForLinux:

i. Perform the same command for the default directory in
~/Android/Sdk/platform-tools/adb ora Terminal type

whereis adb and look for the directory

-20 -



Adding App to Emulator

Adding App to Emulator

In Android Studio, the Device Manager interface helps you to configure an Emu-

lator or Physical Device.
1. Choose between a Virtual or Physical Device.

2. Click Create device and follow the instructions.

3. When you finish the process, deploy the app by clicking the Play icon.

4. Install the app by using drag and drop from the apk or installing it from the
Play Store. If you are using an emulator, be sure to install an Android ver-

sion with Google Play Services.

-21-
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Required Fields

The minimum required parameters to set up a configuration file from the app

are:

appPackage

appActivity
udid

platformVersion

The parameters can be obtained depending on the source of the app (self-app,

downloaded from the app store)

Refer to "Creating a Mobile Configuration File" on page 36 for information on

how to build a file configuration.
Getting parameters from ADB
Parameters can be found using adb:

1. Navigate to the adb path. See "Android Studio Setup" on page 16 for

information on the adb location.

2. Install the app in the emulator or physical device (the emulator can be

downloaded from the app store or just drag and drop apk to the emulator).
3. Open the app in the Emulator/Physical Device

4. Inthe console/Terminal type: adb shell pm list packagesto
obtain the package name “appPackage” ( search for it in the list with a

name similar to the app, for instance, com.mobile.myapp).

-22 -
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5. For main activity “appActivity“ type: adb shell dumpsys package

com.mobile.myapp

Example result: adb shell dumpsys package com.over-

drive.mobile.android.libby

Activity Resolver Table:

Schemes:

dewey-oauth:

3969bfc com.overdrive.mobile.android.libby/com.over-
drive.mobile.android.nautilus.ui.Activity_Main filter f2f78a6
Action: "android.intent.action.VIEW"

Category: "android.intent.category. DEFAULT"

Category: "android.intent.category. BROWSABLE" ......

extractNativeLibs=false

primaryCpuAbi=null

secondaryCpuAbi=null

cpuAbiOverride=null

versionCode=520000 minSdk=21 targetSdk=33
minExtensionVersions=[]

versionName=5.2.0

usesNonSdkApi=false

splits=[base]

apkSigningVersion=2
UDID can be found just by typing: adb devices

Example: adb devices

-23.-
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List of devices attached

emulator-5554 device

-24 -



Creating a Smart Tag File for Visual Accessors

Creating a Smart Tag File for Visual
Accessors

Visual accessors use a new type of Smart Tag called Image Reference. It can

be provided from a URL or a repository.
1. In AlQ navigate to Mobile Designer > Smart Tags Workbench.
2. Inthe Category field, select Image Ref.

3. Enter a Smart Tag Name.

8080/U/MobileDes

fTags htmiZpath= e w *»O00O :

= appvanceqi
s ractons  Validations Settings

& Dashboard File~

Smart Tags +
0 bl Designer

IDE
Smart Tag Name

JS Edit & Play

ype
‘Smart Tags Workbench Note: Smart Tag name should begin with a lstter and not contain spaces.

Validations Workbench Smart Tag Description

Mobile Conig

Scan Mode
Select an option below (recommended). In the avent no optins are salected, a new Smart Tag acton wilbe added every time a Srmart Tag s identiiod
One Per Page D  OncePerApp D  Singleton >
Scan only frst matching olemont for cach Scan all matching olemants from only one Scan an eloment which only oxists once
page. Example: A Hore button present page. Example: Anavigaton bar which in the entiro application. Example: Login
cross many pagos. oxists across many pages. cloments.

Images +

Image URL

4. Click on the plus next to Images.

5. You can enter a URL for the target in the URL field, or use the Browse but-

ton to upload an image from an existing repository.

6. To add more Smart Tags in the same file, click Add in the top right section
and repeat the same steps. When all Smart Tags are created, save them

in a file by clicking on the file menu.
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Considerations

* Smart Tag images can have as many targets as necessary, just click on

the plus icon next to Images to add more fields.
* ifjusta URL is provided it must be public access.

* If you are using a repository, it must be configured in AlQ, Navigate to

Global Options > Preferences > Repositories.

x oo locahost x| + vo- a x
<« C O localh ences html oW w »O0@ :
= appvanceaqi appvance

@ Dashboard
Repository ~ Reports  APMIntegration  Git Credentials  EC2 Credentials AIQ Credentials

¢ Test Designer
eeeee

. S . Last updated (yyyy-MM-dd): Pull selected repository  Checkout Branch  Clone Repository
Owobie Designer
& Al Scrpting < . - . .
Type Name (Case nsensitve) Branch

Wl Service Suite < Gt v testname
 Scenarlo Editor

»> Play e

i Analyze

= DPL Options Password / SSH (If your account uses 2FA provide the access token instead of the password)

] Password / Token
il Tatfic

2 Global Options

Proxy Optior
Output Logs
Select an opt
AIQ Status
DT e
Gloud Config
Monitor Config S
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Generating Images for Smart Tags

Generating Images for Smart Tags

The Mobile Designer IDE allows you to play and record actions, besides crop-

ping images from the device screen.

For taking images for your Smart Tags:

—

Open an emulator and start an Appium Server.
2. In AlQ navigate to Mobile Designer.
3. Click Record.

4. Load a file configuration. See Mobile Blueprint Enhancements for inform-

ation on file configurations.

5. Click and navigate through the application and crop the images by draw-

ing rectangles.

« C © localhost8080/Ul/MobileDesigner/IDE htmizfle=#

= appvanceaqi

@ Dashboard Fie v oOptions v Edt v [0

Diobie Designer - -
,
Mobile Config
& Al Scripting
W Service Suite < Logs  Data
# Scenario Editor
all Traffic:

2 Global Options

6. Click Save and save the images in your repository or local drive.
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Considerations

* |t could be helpful to add multiple images from the same target taken using
different methods at different sizes (preferably bigger than the original

size).

* You can use the emulator to take a screenshot and crop images by using
an image editor or just you could use basic cropping functionality from the

OsS.

* Images must be saved in a repository or a public URL.

-28-
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Creating a Mobile Blueprint using
Visual Accessors

1. In Appvance IQ navigate to Al Scripting > Create Blueprint.

2. Click Mobile to create a mobile blueprint.

Mobile

‘‘‘‘‘‘‘‘‘‘

3. Load your device configuration file. Click Browse, search for the file and

load it.
4. In Scan Type choose Smart Tags or Smart Tags + Tags and click Next.
5. Create a new execution and give it a name.

6. After clicking Create, the Blueprint will be running.

-29.-
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Create Execution

Execution Name:

( ) Use only one Dataset at a time

voreste e

Total Selected Datasets. 1

SelectAll  Deselect All

pe

Hash DPL - Reads CSV, provid v

.oad Dataset from CSV file Create ® Close

Once the Blueprint finishes, the execution results display.

5 Appvarce IQ: Bluepint X o Apprance 1Q UserGuide - Mobile X | v - a x

< C O localhost8080/Ul/Blueprint/Create htm cw e w »00

= appvanceaqi appvance

& Dashboard File ~  Options ~+ m 1 10 216 0 00:07:04.

Devices  Pages Found | Actions Found  Remaining Actons | Durafon (nfmmss)
8¢ Test Designer <
Basic  Execution Management (obile) ~ Requests  Reports  Validations  Smart Tags Not Running
O mobite Designer
& Dataset Manager |+ Add Execution
& Al saripting
Define input data for the Blueprint using the Dataset Manager. Click Inputs Found link to show all found pages with inputs to be defined.
[ — Map desired inputs with corresponding variables defined in Datasets and then diick the Execution’s Play button to continue Blueprint
Compare Blueprints. Actions  Remaining  Duration Faled  Inconsistent
Name Gontrol Panel Dataset Devices  PagesFound | oions red orery stz oted | Incormisem
Blueprint Template Editor o
Inputs . S Rety
st &1 Dataser 265 L ot Runving
e test s s o o o 000704 NolR S

Coverage Map
il Service Suite <
# Scenario Edior

» Play

Lt Analyze

SDPLOptons <

il Tratfic: -
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Android Mobile App Example

The following sections provide a complete end-to-end example of using the

visual accessor functionality to test a mobile application.

The Android version of the Universe mobile app by Alpha Software is used for

the example.
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Selecting the Mobile Device and App
in the Device Manager

In this section you will select a mobile device to emulate and install the example

mobile app. This example uses a Pixel 2a as the emulated mobile device.
1. Open Android Studio.
2. Click on Device Manager > Create device> Virtual.
3. Select Category > Phone.

In the Name column select Pixel 2a with Play Store 5.6” Resolution: 108
2210, 440dp.

"

Note: Make sure the device has a Play Store icon (blue
square) associated with it.

4. Click Next.

5. Inthe Release Name option select Tiramisu and click Next.
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Selecting the Mobile Device and App in the Device Manager

0 System Image

Select a system image

Tiramisu

API Level

Tiramisu 33 droid e 33
*

Android
Tiramisu
Google Inc.

Note: The Android version of the emulator displays in the
Device Manager.

s

6. Accept the default settings. Be sure that Portrait is selected.
7. Click Finish.

8. Start the emulator by clicking the Play button.
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"]

Note: Device Manager, Play button, and Emulator are
highlighted in red.

9. Click at the center of the phone emulator and drag it up to show the avail-
able apps. Choose the Play Store.

156 9 A @ v

Note: The emulated phone menu, Play Store highlighted
in enclosed in red square.

10. Search Play Store for the Universe app by Alpha Software and Install it.
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Selecting the Mobile Device and App in the Device Manager

1569 & @ van
G U0
Q@O =
o Camera Chrome Clocl Jotact

You are now ready for the next step, "Creating a Mobile Configuration File" on
the next page.
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Creating a Mobile Configuration File

A Mobile Configuration file is required to describe which app will be launched

during the Play/Recording/Blueprint.

1. In AlQ navigate to Mobile Designer > Mobile Configuration.

x o+
C @ localhost8080/Ul/MobileDesigner/config htmi o2 % O & i

<
= appvanceqi appvance

& Dast

Neme

@ Config O Open B sve B Swveds & Clear

Source Physical Device:

Gt e

2. Thefirst step is to get the basic parameters from the Device. Open a Con-

sole/Terminal in the adb directory.

"]

See "Setting up the Environment" on page 13 for inform-
ation on how to get the directory if a variable path is not
assigned to it.

3. Open the Universe app in the Device Emulator and perform the following

steps:
a. UDID: adb devices

List of devices attached

emulator-5554 device

So: UDID=emulator-5554
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Creating a Mobile Configuration File

b. appPackage: adb shell pm list packages

package:com.android.traceur
package:com.android.contacts
package:com.google.android.apps.messaging
package:com.ed.universe
package:com.android.internal.emulation.pixel_3a_xI
package:com.android.location.fused

package:com.android.vpndialogs

It returns a list with active packages, and searches for the app name,

in this case, Universe (appPackage=com.ed.universe).

c. Activity/appActivity: adb shell dumpsys package com.ed.uni-

verse

Activity Resolver Table:

Non-Data Actions:

android.intent.action.MAIN:

237c878 com.ed.universe/.MainActivity filter 5a51b51
Action: "android.intent.action.MAIN"

Category: "android.intent.category. LAUNCHER"
.DayInDetailActivity:

7457fb6 com.ed.universe/com.edu.sundroid.DayInDetailActivity fil-
ter 24504b7

Action: ".DayInDetailActivity"

Category: "android.intent.category. DEFAULT"

versionCode=37 minSdk=21 targetSdk=32
minExtensionVersions=[]

versionName=1.7.4
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usesNonSdkApi=false
splits=[base, config.arm64_v8a, config.en, config.xxhdpi]

apkSigningVersion=3
appActivity=.MainActivity

Also, AndroidVersion appears as targetSDK = 32 (it can be an upper

version if OS is supporting it)
4. Now fill the Mobile Configuration Panel with the parameters
a. Name the configuration.
b. In Source select Package.

c. In Capabilities add "noReset": "true" to prevent the app from

asking repeatedly to log in.
d. Accept the default parameters for the remaining fields.

e. Save the configuration as "UniverseConfiguration”.

= appvanceqi

@ Contig 0 Open B swe B Swes & Clear
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Verifying the Mobile Configuration File

The file configuration can be opened in text format:

"configName": "UniverseConfig",

"app": "%,

"appPackage": "com.ed.universe",

"proxyURL": "",

"bundleId": "",

"source": "package",

"appActivity": ".MainActivity",

"deviceMode": true,

"service": "On-Premises",

"serverURL": "http://localhost:4723/wd/hub",

"platformName": "Android",

"validDomains": "",

"capabilities": {
"platformVersion": "33",
"udid": "emulator-5554",
"systemPort": "8201",
"deviceName": "Device",
"noReset": "true" }

Testing the Configuration

For testing, if the configuration is correct,
1. Start an Appium Server and an active emulator.
2. In Appvance IQ navigate to Mobile Designer > IDE.

3. Inthe File dropdown select New.
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4. Click Record.
5. Add the configuration you created. Wait until the app is launched.

* If there is a problem with the configuration, it will display in the log or
the Appium Inspector. Use the log file to fix any configuration issues.
Typically errors are related to incomplete names or copied para-

meters. Use the example file above to help.

* If there are no configuration errors, you will see the emulator with the

Universe app running in AlQ.

« (<2}

= appvanceai apprance

You are now ready to proceed to the next step "Getting Access to a Repository"

on the facing page.
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Getting Access to a Repository

In order to save images Appvance IQ can connect to a repository.

1. In AlQ navigate to Global Options > Preferences > Repository.

<

= oppvanceai appuance

@ Dashboard
Repository ~ Repors  APMInlegiation  Git Credentials  EC2 Credentials  AIQ Credenials.

DemoRepo I oot vrcatea tvy-amca: 202211109 143529 Pull selected reposiory  Checkout Branch  Clone Repository
Type Name (Case Insensiive) Branch: MAIN

¢ Test Designer

Cnobie Designer

G v DemoRepo
» Py URL
itps:/gitab com/AIQBIueprinsimobileblueprint gt Public
Lai Analyze
SDPL Options < Usemame coount uses 2FA provide the access token Instead of the password)
dast
lTraffc

2 Global Options

Output Logs

Default Comit Message Status

Ds3 WORKING

Stacktrace:

2. Suggested parameters:

* Name: DemoRepo

* URL: https://gitlab.com/AlQBlueprints/mobileblueprint.git

* Username: user name with access to the repository

* Password: user password, if not working please contact Mobile

Designer Team for a Token

* Visibility: Public

e Type: GIT
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"]

Those parameters can be changed if the user has access
to another repository.

3. Click Clone Repository (Repository Successfully saved if everything is

correct, if not check your parameters )

4. Anytime a file or document is saved or loaded it can be accessed from the

repository in ROOT > REPOSITORY > name_repo.

ROOT / REPOSITORY

A Quick Access REPOSITORY Q. search..
= HOME
[ woe R e =
v My Computer
yomp DemoReno 11/09/2022 14:42
C
’ HOME 08/22/2022 14:34

You are now ready to perform the next step, "Taking Images as Possible Smart

Tags" on the facing page.
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Taking Images as Possible Smart Tags

Taking Images as Possible Smart
Tags

Visual accessor functionality allows you to use graphical representations as pos-

sible Smart Tags. Images from the application can be obtained from Mobile

Designer IDE in the Recording.

Follow these steps to get some images from the Universe app.

—_—

5.

6.

Start an Appium Server and an Emulator.
In AIQ navigate to Mobile Designer > IDE.

Click Record and load the configuration file that you created in "Creating a

Mobile Configuration File" on page 36.

Wait until it loads and then draw a square around the HOME button.

x| @ inde

« C @ localhost8080/UI/M

& Dastvoard Fle -~ optons - Edt s

=
@ Test Designer < W Pase M Stop -
O mobile Designer

JS Edit & Play

Mobile Conig
& Al Scrpting <
i Service Sute < Logs  Data oY
# Scenarlo Editor ad -
» Play

Lt Analyze

Z=DPL Options

all Traffic

¢ Global Options

Click Save and search for ROOT > REPOSITORY > DemoRepo > Tar-

gets and save it as "UniverseHome".

Click on Home.
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7. Draw a square around the Rocket image and save it as "UniverseRocket".

5 Appuance 1Q: Mobile IDE

X | @ Indexof REPOSITORY/DemoRer: X |+ v - o0 x

€ 5 C O localhost8080/Ul/MobileDesigner/IDE htmlfile=# oW & RO &

appvance.Qi appvance

@ Dashboard File ~

options ~  Edit ~

@ Test Designer < | W Pase M Stop

Device XML

No Action Accessor Value Description @
0 mobile Designer Astroverse
1 Use Configuration 'SERVER(C:/UsersiDie...  ‘UniverseConfig
_ 2 set ° A
S Edit & Play 3 ok byld(com.ed.universeiidihome") . o

‘Smart Tags Workbench
Vaiidations Workbench
Mobile Gonfig

& Al scripting ¢

0 Senvice Sute ¢ Logs  Dats

# Scenario Edor

Space Gallery

»> Play

il Analyze tivity", "appPackage:"con.ed.universe®, 'noReset” s "true®, ol

= 0PL Options <

lTraffic B
»

o Giobal Options <

8. Click on Content from Astroverse located above Rocket Image.

9. Draw a square around the Solar System image and save it as "Uni-

verseSolarSystem".

Mobik IDE X | @ Indexof REPOSITORY/Demofep: X | v - o x

© localhost:8080/Ul/MobileDesi

r/IDEhtmi?fle=#

oW ¥ » 02

ppvance.Qi appvance

& Dashboard File v  Options v  Edit ~

@ Test Designer < | W Pase W Stop

Device XML

. No Action Accessor Value Description @
Cmobie Designer . o Astroverse
_ byld{comed.universeddhome’)
4 byAccessibiltyld("Astr
Js Edit & Play
5 byld("com.ed.universe:amome”)
‘Smart Tags Workbench 5 e —
Validations Workbench 7
8
Moblle Conflg
s byld("com.ed.unive e)
% Al Scripting <
A 0 ok byXPath(*/androld widget TextView[@text=Content .
Wl Service Sulte <

# Scenario Editor

» Play

il Analyze ", apprackage” 4 Reset™:"true®, "p
Z=DPL Options a

il Traffic S
& Global Options <

You are now ready for the next step, "Creating the Smart Tag File" on the facing
page
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Creating the Smart Tag File

The following process demonstrates creating a Smart Tag File for the Universe

app.

Note: You must have a connection to the repository to perform
this task. See "Getting Access to a Repository" on page 41.

1. In AlQ navigate to Mobile Designer > Smart Tags Workbench.

2. Define the following parameters:

* Smart Tags Name : Home

* Category : ImageRef

* Smart Tag Type : Navigation

> c

= appvance.qi apprance - B

@ Dashboard - Summary  SmartTags  Actions  Extractions  Valdations  Settings

@ Test Designer

0 Wobie Designer < |cp osse
3 Smart Tag
J5 e Py Home

& Al Scrpling
Scan Mode

Select an option below (recommended). In the event no options are selected, a new Smart Tag action will be added every time a Smart Tag is identified

One Per Page @ ) Once Per App ) ) Singleton >

Scan only first matching element for each Scan all matching elements from only one Scan an element which only exists once

page. Example: A Home button present page. Example: A navigation bar which in the entire application. Example: Login
cross many pages. exists across many pages. elements.

i Traffc \mage

Image URL

3. Click on the plus sign next to Images.
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4. Click Browse and search in ROOT > REPOSITORY> DemoRepo > tar-

gets > UniversalHome.

5. Click Show Image to check if the correct image is loaded.

Mobie Smart Tag. X | @ Indexof REPOSITORY/Demakep: X | + v - o8 x
« C @ localhostB080/Ul/MobileDesigner/SmartTags h o BB x %02
appvance.Ql apprance
@ Dashboard Note: Smart Tag name should begin with a letter and not contain spaces.
® Test Designer < Smart Tag Description
0 Mobite Designer N
IDE
Scan Mode
JS Edit& Play
Select an option below (recommended). In the event no options are selected, a new Smart Tag action will be added every time a Smart Tag is identified
‘Smart Tags Workbench .
EEEEEE o (D owerermm > Snoen >
Validations Workbench Scan only first matching element for each Scan all matching elements from only one Scan an element which only exists once
page. Example: A Home button present page. Example: A navigation bar which in the entire application. Example: Login
Mobile Config across many pages. exists across many pages. elements
& Al Sciipting <
0 Senvice Sute < Images +
# Scenario Editor Image URL
SITORY/DemoRepolt
» Play
Ll Analyze
= oL opions . HOME
Al T
8 Global Options R
v - o x
< o &
appvance:
@ Dashbosrd File~ Summary  Smart Tags Mobile (1)  Actons  Extacions  Valdations  Seftings
¢ Test Designer
Smart T Category u
0 Mobie Designer v - Image Ref v D Disabe
Smart Tag Name Smart Tag Type
D€
Navigation .
IS Edit & Play Nota: Smart Tag name shouit begin wilra eftr and nof contain spacas

Smart Tag Description

Validations Workbench

Mobie Config Scan Mode
Selecten opion below (recommended). It event no options are selecied, anew Smt g actonvillbe added every ime a SmertTag s dentfed.
& Al Scripting
One Per Page > Once Per App ) ] Singleton
W Service Suite Scan ony g clement forcach Scan all matching lements from only o Scan an element whichany eists once
page. Example A Home buton present page. Example: Anavigaton bar which inthe entre apicaton. Example: Login

# Scenario Editor

> Play

Images +
a1 Analyze |mage URL

tp/localnost 8080/Appvance: nce REPOSITORY/DemoReportargetsUni
= DPLOptons
il Trafic

8. Create a new Smart Tag named "Rocket" in the Smart Tags Name field.
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10.

11.

12.

13.

14.

Click the plus sign next to Images and search for "UniverseRocket" in the

repository.
Click Add.

Create a new SmartTag named "SolarSystem" and browse for the "Uni-

verseSolarSystem" image.

Click Add.

In the File dropdown, select Save and save it as "Uni-

verseSmarttagsDemo".

The saved file has the following structure:

"categoryId": "ImageRef",
"threshold": "0.75",
"smartTags": [

{
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"name": "Home",
"category": "ImageRef",
"type": "Navigation",
"tags": [

http://-

loc-
alhost:8080/Ap-
pvanceServer-
/rest/pub-
lic/ap-
pvance/REPOSITORY/DemoRepo/targets/universeHome.png"
1y
"rules": [],
"info": {},

"disabled": false,

"description": ""
"singleton": false,
"scanOncePerApp": false,
"scanOnePerPage": false
by
{
"name": "Rocket",
"category": "ImageRef",
"type": "Navigation",
"tags": [
"http://-

loc-

alhost:8080/Ap-
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pvanceServer-
/rest/pub-
lic/ap-

pvance/REPOSITORY/DemoRepo/targets/UniverseRocket.png"

by

loc-

alhost:8080/Ap-
pvanceServer-
/rest/pub-

lic/ap-
pvance/REPOSITORY/De-

1,

"rules": [,
"info": {},

"disabled": false,

"description": "",
"singleton": false,
"scanOncePerApp": false,
"scanOnePerPage": false
"name": "SolarSystem",
"category": "ImageRef",
"type": "Navigation",
"tags": [

"http://-

moRepo/targets/UniverseSolarSystem.png"

1,

"rules": [,

"info": {},
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"disabled": false,
"description": "",
"singleton": false,
"scanOncePerApp": false,

"scanOnePerPage": false

I

"actions": [],
"customTags": [],
"validators": [],

"extractors": []

You are now ready for the next step "Mobile Blueprint using Visual Accessors"

on the facing page.
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Mobile Blueprint using Visual
Accessors

This section demonstrates creating a Mobile Blueprint using visual accessors

for the Universe app.
1. Start an Appium Server and an Emulator with the Universe app installed.
2. Open the app in the Emulator to verify everything is working correctly.

3. In AlQ navigate to Al Scripting > Create Blueprint.

« c

= oppvance.

@ Dashboard File ~  Options ~
¢ Test Designer

O mobite Designer ‘ Mobile

& Al Scrpting

Create Blueprint

Compare Blueprints

mplate Editor

il Analyze

= DPL Options
il Traffic

o Giobal Options

4. Click Mobile.

5. Select the configuration file for your device. Click Mobile Configuration

>Browse and load "UniverseConfiguration”.

"UniverseConfiguration". is the file you created in "Creat-
ing a Mobile Configuration File" on page 36.

6. In Scan Type select Smart Tags.
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7. Click Browse next to Smart Tags Library Path and load the "Uni-

verseSmartTagsDemo" file.

"UniverseSmartTagsDemo" is the file you created in
"Creating the Smart Tag File" on page 45.

3 C O localr

@ Dashboard File =  Options + [ 0 o [ 00:00:00
, fons || Duration (hhmmss)

Basic  Execution Mana gement (Mobile)
Service: Platform: Source: Scan Type:

v Android (Native) v Package v SmartTags
@) visuaiHints () Validations Library  ( J) Al Hints ( Driles () setup

Smart Tags Library Path:

Packag
W Service Suite
 Scenario Editor Activity:
» Play B
Valid Base URLS:
Ll Analyze i
SDPL Options
Mobile Configuration: & Template ~Physical Device
AlTraffc

4 Global Options

8. Click Next.

9. Create a new execution with the name "UniverseDemo".

10. Click CreateThe Blueprint will run.

Create Execution [ x}

Execution Name:

\ ) Use only one Dataset at a time

bt o

Total Selected Datasets' 1
SelectAll  Deselect All
Type

Hash DPL - Reads CSV, provid v

'@ Load Dataset from CSV file M Create ® Close

11. To view the search while the Blueprint is running refer to the Emulator.
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12.

13.

14.

Result : List of pages and actions found.

o Appuance 1Q: Blueprint X @ Indexof REPOSITORY/Demoep: x | + v - 8 x
« ' © localhostB080/Ul/Blucprint/Create htmi# - ma e
@ Dashboard = ke - optons - [ 00013
Osices  PaaFong | Acton Found | Remsinng ctons | Dursion (s
¢ st Designer < Basic  Execution Management (Mobile)  Requests  Reports  Validations  Smart Tags

Not Running

Define nput data for the Blueprint using the Dataset Manager. Click Inputs Found ink o show al found pages with inpus to be defined.
& Al Scripling v Map desited inpuls wilh cortesponding veriables defined in Detases and then cick the Execulion’s Play b

uton to contnue Blueprint

Name Contro panet Datase Devces  PogesFound | ActonsFouna | Romamin pe= Saus  Foledacions Mo
bl 3 Actons mss) “nctons

Compare Blueprints Umassdne s Found o 4 amve o ot Not o
Blueprint Template Editor Pages wi nputs: Al Pages. .
> 1 Custon Actore mamatana Soace St
Generate Scripts > 1 Custom ctons) ssovese
11 Gustom ctors) Asrovrse
Coverage Ma
90 Map. » 0 st ctoney ik
i Service Sute < 1010 v Pt

# Scenario Editor
™

1l Analyzo

= 0pL options ‘

A Tratfic

Result : Home Smart Tag found.

@ Appvance : Blueprint X @ indexof REPOSITORY/Demofiep: X | + v~ - o X

<« C  © localhost8080/Ul/Blueprin

reatehtmi#

oW QR x 02

@ oastooars Fie + optors ~ (@

0.0t
Doves PagosFaund | Actons Found | Romsing Acons Dualon (s
¢ Tost Dosigner < || Basic  ExecutionManagement (obile)  Requests  Reports  Valdations  Smart Tags Not Running
L — - (==
Define input data for he Blueprin usig he Dataset Manager.Clk npus Found nk o show ol found pages wihinpuls o be defined.
& A scriping . Wap desitd inputs <poning varblesdefind i Dalasets and then cck he Executon's lay bulfon o continue Bleprn
o Blueprint vame pr—r— oaaet Oovces | pasfond | AcionsFond RN M saws kAo TR
SR s iosrans | 1omses . . [ o worat vetrunang
Blueprin Templte Edfor [ — .
11 ot Acors st pce sion e
Generat Scrpts
s~ Brncenos
Coverage Map e o g
oo @ oo v 1
W Servea Sute « e .
ootorg v
# Scanaro Edtor asnnss v

» Play

Qe ona International Space
i Aneze ;
0P optons < Station

il Tratic

Result : Rocket Smart Tag found.
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i Apprance (Q: lueprint X | @ Indexof REPOSTORY/Demofier X | + v - 8 X
<« C @ localhost8080/Ul/Blueprint/Create html# o QR x » 02
PPvanc appvanc
@ Dastboard Fie ~ options + [ 4
Omvices | PagesFound | Acions Found Ramaing Acons | Duson (i ss)
¢ Tost Designer « Basic  Execution Management (obile) ~Requests  Reports  Validations  Smart Tags Not Running
Ditole s « S
Dafine iaput data for tha Bluaprint using the Dataset Manager Gick Inputs Found ik 0 show al ound pages with inputs fo bo dofned

& A serping - Map desirad nputs it corsponding variabes defined in Datasets and hen clck ho Execition' Play buffon o contnue Blusprint

roate Blueprint = Contopane Oatat Dwvcss | Poesfond  Actonsoud | eronna  Duner Sas  FaiedAcions  onssent

Compare Bhueprints Unvaestama s 1 Dsses o i s o LT -

Blueprint Templte Editor Pages e s A1 oges v

1 st At ) spca S

Generate Scripts 11 Custom actons Asroverse otemaze

Coverage Map g B~ |
W Service Sute < jien 1) Rock @ oononns v 1

Conemms v s B
# Scenario Edior Frcessalrie bty -
memaisze  Dononn .

» Py -
at Analyze Brcarcaontotna
= DPL Optons <
il Tatfc

15.

: Appvance 0 Bueprint X @ Indexof REPOSITORY/Demoriep: x | + vo- o x
€« C O localhost:8080/Ul/Blueprint/Create htmi# o & Q 12 H
appvanc
@ Dastboars Fie -~ optons ~ [ s . o
Oevkss | PagesFount | Actons Fund | RemaingActons | Ourston (1)
¢ Tost Dosigner < | Basic ExccutionManagement (Mobile) Requests Reports  Validations  Smart Tags Not Running
Dttt voser - =S
Dofie aput data fo tre Blueprin using tho Dataset Manager Gick nputs Found nk o show al ound pages wih inputs fobe defined
& A Serping - M desed inputs i corasponding variabiesdaned in Datasets and hen clck tho Exacuion's ly bt fo coniue Blueprint
roato Bioprint e p—r— ot Oevkss  oeeroun Aciomsroma | S0 DU g s e
Compare Bueprints st by 81O o . v . PR
Blueprint Template Edtor st s A poen .
EEEEDERTS <1 Custom Actons) Astroverse
11 Custom Acons stoverse eimase
Coverage Map
s Bressciorosan | * Answers to big
DETDELD ‘ i creed Significant Person questions
oo ooons ~ | 0
# Scenario Edor et © o v 1
Nevgaton oonaney v
> Play e sy oonanny v o
ootoms o -
i Analyze Frcsmsour covenny -
Werasits Doty e
= 0pL Options <
oo
- Traffc @rsociniotns

16.

Result : Solar System Smart Tag found.

Solar system

Save the results "Actions Found" and in File save the Blueprint.
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